[Top] [All Lists]

Re: IMQ again WAS(Re: iptables breakage WAS(Re: dummy as IMQ replacement

To: Andy Furniss <andy.furniss@xxxxxxxxxxxxx>
Subject: Re: IMQ again WAS(Re: iptables breakage WAS(Re: dummy as IMQ replacement
From: Andy Furniss <andy.furniss@xxxxxxxxxxxxx>
Date: Mon, 28 Mar 2005 14:39:03 +0100
Cc: hadi@xxxxxxxxxx, Harald Welte <laforge@xxxxxxxxxxxx>, Patrick McHardy <kaber@xxxxxxxxx>, Remus <rmocius@xxxxxxxxxxxxxx>, netdev <netdev@xxxxxxxxxxx>, Nguyen Dinh Nam <nguyendinhnam@xxxxxxxxx>, Andre Tomt <andre@xxxxxxxx>,, Damion de Soto <damion@xxxxxxxxxxxx>
In-reply-to: <42470AF9.8050402@xxxxxxxxxxxxx>
References: <1107123123.8021.80.camel@xxxxxxxxxxxxxxxx> <423F41AD.3010902@xxxxxxxxxxxxx> <1111444869.1072.51.camel@xxxxxxxxxxxxxxxx> <423F71C2.8040802@xxxxxxxxxxxxx> <1111462263.1109.6.camel@xxxxxxxxxxxxxxxx> <42408998.5000202@xxxxxxxxxxxxx> <1111550254.1089.21.camel@xxxxxxxxxxxxxxxx> <4241C478.5030309@xxxxxxxxxxxxx> <1111607112.1072.48.camel@xxxxxxxxxxxxxxxx> <4241D764.2030306@xxxxxxxxxxxxx> <1111612042.1072.53.camel@xxxxxxxxxxxxxxxx> <4241F1D2.9050202@xxxxxxxxxxxxx> <4241F7F0.2010403@xxxxxxxxxxxxx> <1111625608.1037.16.camel@xxxxxxxxxxxxxxxx> <424212F7.10106@xxxxxxxxxxxxx> <1111663947.1037.24.camel@xxxxxxxxxxxxxxxx> <1111665450.1037.27.camel@xxxxxxxxxxxxxxxx> <4242DFB5.9040802@xxxxxxxxxxxxx> <1111749220.1092.457.camel@xxxxxxxxxxxxxxxx> <42446DB2.9070809@xxxxxxxxxxxxx> <1111781443.1092.631.camel@xxxxxxxxxxxxxxxx> <4244802C.7020202@xxxxxxxxxxxxx> <1111788760.1090.712.camel@xxxxxxxxxxxxxxxx> <42470AF9.8050402@xxxxxxxxxxxxx>
Sender: netdev-bounce@xxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b) Gecko/20050217
Andy Furniss wrote:
jamal wrote:

I'll have to re-run a test I did recently which was lots of tc filter matches at 8000pps - on egress IMQ was almost as good as directly on eth0. On ingress it was more than 10X worse.

How many filters? I wont suspect any difference between ingress and egress.

You are right - the test was to blame.

I was using my old PC as sender, it's frozen in time at 2.4.20 which for some reason has a txqueuelen on eth0 of 0. It doesn't show using netperf when just testing LAN speed - but makes alot of difference for the test I did - ifconfig eth0 txqueuelen 1000 fixed it.

Hmm - I just tried to recreate another test I did - which was using IMQ to shape for a single duplex link. I was going to redo it with dummy, but don't seem to be able to put an egress filter on eth0 - eg. Your example from the first post in this thread -

What you can do with dummy currently with actions

Lets say you are policing packets from alias
you dont want those to exceed 100kbps going out.

tc filter add dev eth0 parent 1: protocol ip prio 10 u32 \
match ip src flowid 1:2 \
action police rate 100kbit burst 90k drop

Gives me -

RTNETLINK answers: Invalid argument
We have an error talking to the kernel


<Prev in Thread] Current Thread [Next in Thread>