xfs
[Top] [All Lists]

Re: RedHat Linux 7.0 with SGI XFS

To: Juan Casero <casero@xxxxxxxxxxxxx>
Subject: Re: RedHat Linux 7.0 with SGI XFS
From: Russell Cattelan <cattelan@xxxxxxxxxxx>
Date: Wed, 21 Feb 2001 23:42:50 -0600
Cc: Eric Sandeen <sandeen@xxxxxxx>, linux-xfs@xxxxxxxxxxx
References: <3A947AA9.F12C2572@xxxxxxxxxxxxx> <3A947A20.6E79C8BF@xxxxxxx> <3A94A67D.35BFD64C@xxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
Juan Casero wrote:

> Ok.  I did what you told me to do below and I ran into another problem
> possibly a bug.
>
> I downloaded a plain vanilla 2.4.0 kernel.  Applied the
> Feb062001prerelease.patch
> and configured the kernel.  I checked to make sure that the kgcc line was
> uncommented
> in the top level Makefile of the kernel source tree and went ahed and
> installed the kgcc
> package from the RedHat CD.  I configured the kernel and just to be safe
> decided to send
> a binary image to the floppy disk in the dive rather than muck around with
> the kernel images
> on the disk.  So here is the commands I issued:
>
> # make dep;make clean;make bzdisk

Umm well that isn't going to work :-(
The kernel with XFS compiled in will be to large to fit on a floppy.

If you are concerned about kernel versions simply modify the flag
EXTRAVERSION in the top level Makefile to some unique name.
Add the new kernel name to /etc/lilo.conf
Then run:
make clean depend bzImage modules install modules_install


The reset is odd... probably a general linux bug rather
than an XFS specific bug.

>
> Well the compile seem to go ok but when the make file started to copy the
> kernel image
> to the floppy disk in the drive suddenly the system rebooted!  I did this
> twice and each time
> before the kernel image dump could complete the system spontaneously
> rebooted.  The upside
> of this is that I was able to see the journaling features of the XFS in
> action or should I say not see
> them!  The reboot went smooth as a whistle.  It was almost as if the system
> had been properly shutdown
> and restarted.  It rebooted without even a hiccup!  The down side of this
> though is that this might be indicative
> of a bug in the code.  Any ideas?
>
> I currently use an SMP Pentium III system with 2 processors.  The motherboard
> is a Tyan Tiger 100 Rev B.
>
> Well I guess if I insist on tinkering with beta code then there are some
> inconveniences I will have to live with.
> It is worth it though to be able to use XFS.   Even so if you have any
> suggestions I will gladly try them.  I don't
> think it would be too much trouble to recreate the scenario on a similar
> system in your lab.  I will say though that
> I did install the update glibc-2.2 rpms from redhat's update pages.
>
> Thanks,
> Juan.
>
> Eric Sandeen wrote:
>
> > Juan Casero wrote:
> > >
> > > Hi -
> >
> > > 1.  For some reason when the system boots there is no device file for my
> > > IDE cdrom.  <snip>
> >
> > Nothing to fix - the installed system is using devfs and nodes do not
> > show up until the appropriate driver is loaded.  /dev is a virtual
> > filesystem like /proc so changes are not consistent.  If you turn off
> > devfs you will need to get updated kernel sources from CVS or you will
> > encounter a bug which is masked by devfs.  Read our installer caveats
> > page, and search google for "devfs faq"
> >
> > > 2.  If I download a plain vanilla 2.4.0 kernel and then apply the XFS
> > > patch available the kernel compile will die with an error.   In fact
> > > I even tried to generate the kernel binaries that came on the cdrom
> > > you provide using the source rpms but the compile process also died.
> > > If you like I can send you a copy of the error output from my attempt
> > > to compile the plain vanilla 2.4.0 kernel with the patch
> > > applied.
> >
> > You didn't say what the error is but odds are you need to use kgcc
> > instead of the gcc snapshot redhat provides.  If it dies almost
> > immediately then that's likely the case.
> >
> > Search the patched top level Makefile for "kgcc" and follow the
> > instructions in the comments.
> >
> > > 3.  Trying to compile the NVIDIA_kernel-0.9-6 driver from RPMS succeeds
> > > on this modified redhat 7.0 distribution but trying to load the modules
> > > fails and I get an error message about unresolved symbol irq_stat.
> >
> > I get that too, I haven't looked at it closely - not sure what the
> > problem is, except that binary kernel modules can't really be supported
> > and will eventually break.
> >
> > > By the way.....when do you expect that the source code for XFS will
> > > integrated into the mainstream kernel sources?   That is when is it
> > > likely that we will be able to download a plain vanilla linux kernel
> > > source and
> > > compile it with native support for XFS without having to apply patches?
> >
> > That's up to Linus... :-)
> >
> > Good luck,
> > -Eric


<Prev in Thread] Current Thread [Next in Thread>