xfs
[Top] [All Lists]

Re: Unable to mount SCSI root fs with pr0.10test1 or test2

To: linux-xfs@xxxxxxxxxxx
Subject: Re: Unable to mount SCSI root fs with pr0.10test1 or test2
From: "K. Mitchell Russell" <kmrussel@xxxxxxxxxxx>
Date: Sat, 24 Mar 2001 14:00:10 -500
Sender: owner-linux-xfs@xxxxxxxxxxx
User-agent: IMHO/0.98 (Webmail for Roxen)
I have tried the same thing Chris, installing the base Wolverine, and
it boots fine also.  But still no luck with the XFS installer booting
either SMP or UP.  I'm glad I'm not the only one, or I'd doubt my
sanity.

Thanks for the info Eric.  I don't know what kind of magic words you
used at boottime, but I'm still reproducing the problem on my
hardware.  Are you using any bootprompt commands?  I'll keep trying,
but since I can't even get the system up after running the XFS
installer, I can't very well look at the results of the installer to
determine the problem.  I do know that the kernel panic is at the
point where the VFS is loading root from the initrd, after the ramdisk
is loaded, and before the scsi modules are loaded, not the point of
where it's loading the XFS scsi disk root.

Thanks,
Mitchell

-------------------
> 
> I just ran a clean Wolverine install on an Adaptec equiped machine
and 
> ran into NO PROBLEMS.  This would lead me to believe that the XFS 
> install has in someway changed what anaconda is doing or this has 
> something to do with DFS?  I have not a clue.  Is there anyone who
can 
> clear this up?
> 
> TIA,
> Chris
> 
> 
> Chris Croswhite wrote:
> 
> > I have tried the 10test on another machine with scsi drive. 
Again, I 
> > get the same panic of can not open root device.  Is there a fix
for this?
> > 
> > Chris
> > 
> > Eric Sandeen wrote:
> > 
> >> On 23 Mar 2001 20:14:16 -0500, K Mitchell Russell wrote:
> >> 
> >>> Interestingly, i reinstalled pr0.9, booted up fine.  Then
upgraded
> >>> mkinitrd to 3.0.6, e2fsprogs to 1.19, and installed the
> >>> kernel-smp-2.4.2-SGI_XFS_0.10.i686.rpm from the pr0.10test2. 
Then
> >>> created a new initrd from the 2.4.2-SGI_XFS_0.10smp modules, and
this
> >>> boots fine!  Perhaps there is a problem with the Wolverine
installer
> >>> creating the initrd...
> >> 
> >> 
> >> 
> >> Hm.... well, I did a full scsi install here on an adaptec
controller
> >> (aic7xxx driver) and it's a good news / bad news sort of thing -
the
> >> good news is that it all went fine, and booted right up.  The bad
news
> >> is I didn't reproduce your error.  :)
> >> 
> >> I'll take a look at what anaconda is doing... perhaps there is a
problem
> >> there.
> >> 
> >> Also, I'm not surprised that the boot floppy creation failed -
kernel +
> >> xfs + scsi driver is getting pretty big...  I guess we should
disable
> >> that or at least offer a warning if we can't make it fit.
> >> 
> >> -Eric
> >> 
> >>  
> >> 
> >> 
> >> 
> > 
> > 
> 
> 


<Prev in Thread] Current Thread [Next in Thread>