xfs
[Top] [All Lists]

Re: shutdown umount hangs

To: Krzysztof Rusocki <kszysiu@xxxxxxxxxxxx>
Subject: Re: shutdown umount hangs
From: Utz Lehmann <leh@xxxxxxxxxx>
Date: Fri, 30 Mar 2001 12:38:25 +0200
Cc: linux-xfs@xxxxxxxxxxx
In-reply-to: <20010330121159.B3568@main.braxis.co.uk>; from kszysiu@braxis.co.uk on Fri, Mar 30, 2001 at 12:11:59PM +0200
References: <20010329165519.A7386@tecosim.de> <20010329170446.B7386@tecosim.de> <3AC35E8D.711963C5@sgi.com> <20010329181419.G7386@tecosim.de> <20010329182044.H7386@tecosim.de> <3AC38727.FC9C4FC8@thebarn.com> <20010330115628.A1146@tecosim.de> <20010330121159.B3568@main.braxis.co.uk>
Sender: owner-linux-xfs@xxxxxxxxxxx
User-agent: Mutt/1.2.5i
Are you using lvm partitions?


Krzysztof Rusocki [kszysiu@xxxxxxxxxxxx] wrote:
> 
> Hi,
> 
> I've also had similar problem to yours ..
> 
> When such (let's call it) "hang" occured i tried Emergency Sync
> and Emergency Remount R/O  - it did not work...
> 
> After Alt+SysRQ+B .. system rebooted but i noticed that
> one of my xfs partitions was NOT clearly unmounted
>  - during mount it was recovered...
> 
> Then I tried to reboot ...  yet again "hang" occured..
> And after reboot  the same  partition was 'recovered'..
> 
> I mounted it R/O and xfs_repair'ed ... then mounted R/W..
> 
> And during all next reboots/shutdowns such "hang" has NOT happened any
> more...
> 
> seems strange....
> 
> Cheers
> 
> Krzysztof

<Prev in Thread] Current Thread [Next in Thread>