xfs
[Top] [All Lists]

Unable to mount SCSI root fs with pr0.10test1 or test2

To: linux-xfs@xxxxxxxxxxx
Subject: Unable to mount SCSI root fs with pr0.10test1 or test2
From: "K. Mitchell Russell" <kmrussel@xxxxxxxxxxx>
Date: Fri, 23 Mar 2001 18:48:07 -500
Sender: owner-linux-xfs@xxxxxxxxxxx
User-agent: IMHO/0.98 (Webmail for Roxen)
Dear Colleagues,

I have tried pr0.10test1 and test2, and always get a kernel panic on
boot:

VFS: Cannot open root device "803" or 08:03
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 08:03

This is a SCSI drive on aic7890 controller with all partitions
(/,/boot,/var,/usr,/home) set to XFS at install.

No luck changing ramdisk_size at boottime either (increased ramdisk up
to 100000k even!)

root= was specified correctly at boottime.

XFS-pr0.9 worked like a charm with the stock kernel and initrd
install, so I'm curious why the pr0.10 stock kernel and initrd isn't. 
Probably is not loading scsi module properly.  I recall seeing
something similar some time ago when i compiled a 2.4 kernel from the
xfs devel tree with the scsi_support as a module and not built in.  At
that time, despite configuring the initrd correctly to load all scsi
modules, it would panic as well.  After install i usually compile a
new kernel with SCSI built in, but this is a problem for initial
installing of XFS in pr0.10.  

Once I get my test workstation running again, I will compare the SCSI
options and modules in the pr0.9 kernel and pr0.10 kernel.  In the
mean time, anyone else having a similar problem?

Regards,

K. Mitchell Russell, M.D.
MedITAC Research Lab
kmrussel@xxxxxxxxxxx
www.meditac.com 

<Prev in Thread] Current Thread [Next in Thread>