xfs
[Top] [All Lists]

Problems with SMP version of XFS RH 7.1 installer

To: linux-xfs@xxxxxxxxxxx
Subject: Problems with SMP version of XFS RH 7.1 installer
From: erich@xxxxxxxx
Date: Fri, 18 May 2001 15:34:02 -0700
Sender: owner-linux-xfs@xxxxxxxxxxx
First of all, great job, guys!  Even through all my SMP woes, I haven't
lost data, and it's great not having it FSCK the 40GB XFS partition I
have.  ;)

I have an SMP machine which is crashing or hanging after I've installed
the XFS RH 7.1 set:

  --  dual celeron 550
  --  768MB of RAM
  --  IDE HPT366 w/42GB disk and one large XFS partition.
  --  Intel EEPro 10/100 network

It works fine with XFS RH 7.1 UP, but the SMP kernel appears to be
somewhat buggy (yes, it worked fine on other SMP OSes, and several
prior RH SMP versions).  The problem, in general, only seems to appear
when I try to move my data from another system to this one over the network
(a few times it crashed from untarring/retarring the large >8GB fileset
I'm working with, but I'm not 100% sure there was no network interaction
going on...).

Symptom: try to ftp my 8.5GB tar file from another box to this one, it
would always either:

  --  hang the network card, so no packets are transmitted anymore, and
      occasional errors like "NETWORK TRANSMIT failure" would be in the
      log.
  --  hang the disk drive, but everything else including the network
      is still responding.
  --  occasionally, hang the whole machine.

I tried changing controller and network card types, presuming it might
have been a driver problem, but no dice, identical results.

The overall result makes me think it's some kind of linux 2.4.2 SMP
stability problem, but I'm not sure what other kernel w/XFS to try...

--
    Erich Stefan Boleyn     <erich@xxxxxxxx>     http://www.uruk.org/
"Reality is truly stranger than fiction; Probably why fiction is so popular"

<Prev in Thread] Current Thread [Next in Thread>