xfs
[Top] [All Lists]

Re: 2.4.2 build problems

To: Dave Sill <ds-linux-xfs@xxxxxxxxxxxxxxxxx>
Subject: Re: 2.4.2 build problems
From: Russell Cattelan <cattelan@xxxxxxxxxxx>
Date: Wed, 23 May 2001 15:24:30 -0400
Cc: linux-xfs@xxxxxxxxxxx
References: <wx0vgmsvz7m.fsf@xxxxxxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
Dave Sill wrote:

> The latest chapter in my continuing saga to put together a Dell system
> with two AMI MegaRAID's using XFS...
>
> With the 1.0 (2.4.2) kernel, XFS works, but I get occasional:
>
>    kernel: __alloc_pages: 2-order allocation failed.
>    kernel: __alloc_pages: 0-order allocation failed.

We haven't been able to track this down precisely, but rumor has it
the devel tree which is at 2.4.4 is working better.



>
>
> And--the show stopper for me--the "mtx" tape library utility no longer
> works under the 2.4 kernel, and the mtx maintainer has been laid off
> and says 2.4 has a "busted SCSI subsystem".
>
> Under RH 7.0 (2.2 kernel), mtx worked fine but XFS is not available.
>
> I was hoping that building a custom 2.4.2 kernel with the options I
> know I need might help, but now the kernel build is failing.
>
> Here's what I've done:
>
>   make xconfig, selected my options
>   mv .config ..
>   make mrproper
>   mv ../.config .
>   make oldconfig
>   make CC=kgcc dep clean bzImage modules
>
> It bombs out with:
>
>   kgcc -E -C -P -I/usr/src/linux-2.4/include -imacros
>   /usr/src/linux-2.4/include/asm-i386/page_offset.h -Ui386
>   arch/i386/vmlinux.lds.S >arch/i386/vmlinux.lds
>   ld -m elf_i386 -T /usr/src/linux-2.4/arch/i386/vmlinux.lds -e stext
>   arch/i386/kernel/head.o arch/i386/kernel/init_task.o init/main.o
>   init/version.o \
>         --start-group \
>         arch/i386/kernel/kernel.o arch/i386/mm/mm.o kernel/kernel.o
>         mm/mm.o fs/fs.o ipc/ipc.o \
>         drivers/block/block.o drivers/char/char.o drivers/misc/misc.o
>         drivers/net/net.o drivers/media/media.o
>         drivers/char/agp/agp.o drivers/char/drm/drm.o
>         drivers/ide/idedriver.o drivers/scsi/scsidrv.o
>         drivers/scsi/aic7xxx_new/aic7xxx_drv.o drivers/cdrom/driver.o
>         drivers/sound/sounddrivers.o drivers/pci/driver.o
>         drivers/pnp/pnp.o drivers/video/video.o \
>         net/network.o \
>         /usr/src/linux-2.4/arch/i386/lib/lib.a
>         /usr/src/linux-2.4/lib/lib.a
>         /usr/src/linux-2.4/arch/i386/lib/lib.a \
>         --end-group \
>         -o vmlinux
> drivers/scsi/aic7xxx_new/aic7xxx_drv.o: In function `ahc_run_qoutfifo':
> drivers/scsi/aic7xxx_new/aic7xxx_drv.o(.text+0x4fd8): multiple definition of 
> `ahc_run_qoutfifo'
> drivers/scsi/scsidrv.o(.text+0xefc8): first defined here
> drivers/scsi/aic7xxx_new/aic7xxx_drv.o: In function 
> `ahc_platform_freeze_devq':
> drivers/scsi/aic7xxx_new/aic7xxx_drv.o(.text+0xbd8): multiple definition of 
> `ahc_platform_freeze_devq'
> drivers/scsi/scsidrv.o(.text+0xabc8): first defined here
> ...blah blah blah...
>
> Questions:
>
>  1) Why is the build failing?
>  2) Does anyone have mtx working under 2.4?
>  3) Is there another tape library controller beside mtx?
>  4) Any other advice?
>
> Thanks,
>
> -Dave

--
Russell Cattelan
--
Digital Elves inc. -- Currently on loan to SGI
Linux XFS core developer.




<Prev in Thread] Current Thread [Next in Thread>