xfs
[Top] [All Lists]

Re: quota support for xfs

To: Greg Wildman <greg@xxxxxxxxxxxx>
Subject: Re: quota support for xfs
From: "Christopher \"C.J.\" Keist" <cjay@xxxxxxxxxxxxxxxxxx>
Date: Thu, 7 Jun 2001 14:41:53 -0600 (MDT)
Cc: linux-xfs@xxxxxxxxxxx
In-reply-to: <991936997.17518.22.camel@xxxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
   Still no luck. I put in the changes on the fs/dquot.c file, the
repquota looks to be already patched with the 3.01-pre6 release. Here is
the File system setup from the .config file in the Linux kernel source
tree:

#
# File systems
#
CONFIG_QUOTA=y
CONFIG_FS_POSIX_ACL=y
CONFIG_AUTOFS_FS=y
CONFIG_AUTOFS4_FS=y
CONFIG_REISERFS_FS=y
# CONFIG_REISERFS_CHECK is not set
# CONFIG_ADFS_FS is not set
# CONFIG_AFFS_FS is not set
# CONFIG_HFS_FS is not set
# CONFIG_BFS_FS is not set
CONFIG_FAT_FS=y
CONFIG_MSDOS_FS=y
# CONFIG_UMSDOS_FS is not set
CONFIG_VFAT_FS=y
# CONFIG_EFS_FS is not set
# CONFIG_CRAMFS is not set
# CONFIG_TMPFS is not set
# CONFIG_RAMFS is not set
CONFIG_ISO9660_FS=y
# CONFIG_JOLIET is not set
# CONFIG_MINIX_FS is not set
CONFIG_NTFS_FS=y
# CONFIG_NTFS_RW is not set
# CONFIG_HPFS_FS is not set
CONFIG_PROC_FS=y
# CONFIG_DEVFS_FS is not set
CONFIG_DEVPTS_FS=y
# CONFIG_QNX4FS_FS is not set
# CONFIG_ROMFS_FS is not set
CONFIG_EXT2_FS=y
# CONFIG_SYSV_FS is not set
# CONFIG_UDF_FS is not set
# CONFIG_UFS_FS is not set
CONFIG_PAGE_BUF=y
CONFIG_XFS_FS=y
CONFIG_XFS_DMAPI=y
CONFIG_XFS_QUOTA=y
# CONFIG_XFS_DEBUG is not set
# CONFIG_XFS_VNODE_TRACING is not set

I don't seem to be getting any quotacheck on boot up:

[root@strife linux-2.4.2]# dmesg | egrep -i quota
VFS: Diskquotas version dquot_6.5.0 initialized



C. J. Keist                     Email: cjay@xxxxxxxxxxxxxxxxxx
UNIX/Network Manager            Phone: 970-491-0630
Engineering Network Services    Fax:   970-491-2465
College of Engineering, CSU
Ft. Collins, CO 80523-1301

On 7 Jun 2001, Greg Wildman wrote:

> On 07 Jun 2001 11:50:18 -0600, Christopher "C.J." Keist wrote:
> > Hello,
> >     I have installed RH7.1 using SGI installer CD.  I have compiled the
> > kernel to support RAID with Linear support, xfs , quota and xfs quota
> > support.  I then created a file system appending three disks together, the
> > raidtab file follows:
> >
> > ..snip..
> > 
> > 
> > I was able to create the xfs file system with no problems.  I'm now trying
> > to get user quota to work, but having no luck.  Here is how the file sytem
> > is being mounted in the fstab file:
> > 
> > /dev/md0                /test                   xfs     rw,usrquota     1
> > 1
> > 
> > I have tried just quota,userquota and usrquota for the mount options, all
> > seem to work with no errors in mounting, but all behave the same in that
> > quotas don't work.  When I try repquota -v /test I get the following:
> > 
> > repquota: Not all specified mountpoints are using quota.
> > 
> > mount command shows the following:
> > 
> > [root@strife /etc]# mount
> > /dev/sda1 on / type ext2 (rw)
> > none on /proc type proc (rw)
> > none on /dev/pts type devpts (rw,gid=5,mode=620)
> > /dev/md0 on /test type xfs (rw,usrquota)
> > 
> > setquota does the following:
> > 
> > [root@strife /etc]# setquota jeremy 50000 55000 5000 5100 /test
> > setquota: Not all specified mountpoints are using quota.
> > 
> > I have also downloaded and compiled/install quota-tools-3.01-pre6, still
> > no luck.  Doing strings on the quota commands do show that xfs support is
> > there:
> > 
> > [root@strife quota]# strings /usr/sbin/setquota | egrep xfs
> >   xfs - XFS quota format
> > /proc/fs/xfs/stat
> > 
> > Is all this just telling me that quota support for XFS filesystem on a md
> > raid device is not supported?
> 
> You must have missed my earlier post, so I will repeat it again below;
> 
> There were a few problems running quotas using the SGI RedHat 7.1 iso.
> There is a patch for the kernel at
> http://linux-xfs.sgi.com/projects/xfs/mail_archive/0105/msg00246.html
> 
> and a patch for the repquota command at
> http://linux-xfs.sgi.com/projects/xfs/mail_archive/0105/msg00252.html
> 
> I have recompiled both SRPMS with the patches added and all is working
> great. I won't post the patches and spec file here as they are quite
> large, but drop me a note if you want me to make them available for
> download.
> 
> -- 
> Greg
> 
> Kent's Heuristic:
>         Look for it first where you'd most like to find it.
> 


<Prev in Thread] Current Thread [Next in Thread>