[Top] [All Lists]

RE: XFS on Linux

To: Lucy Upchurch <lucy@xxxxxxxxxxxxxxxxx>
Subject: RE: XFS on Linux
From: daniel@xxxxxxxxxxxx
Date: Thu, 19 Jul 2001 03:41:10 +0100 (WEST)
Cc: linux-xfs@xxxxxxxxxxx
In-reply-to: <3B55CAAA.F13DE913@orion.mc.duke.edu>
Sender: owner-linux-xfs@xxxxxxxxxxx
On 18-Jul-2001 Lucy Upchurch wrote:
> Hi,
> I am trying to install XFS filesystem on a linux box which was running
> Linux 7.4.2.  I downloaded the ISO image from
> http://oss.sgi.com/projects/xfs/1.0_installer.html and made a bootable
> CD.  I selected a custom system.  Before installation, my system loooked
> like this:
> /dev/hda6        1517920         814808         626004    57%    /
> /dev/hda1            23302              8667          13432    40%
> /boot
> /dev/hda10    65275692      10576328    51383552    18%    /home
> /dev/sda1      73885280                  20    70132076      1%
> /home2
> /dev/hda7        1011928          624652        335872    66%    /tmp
> /dev/hda5        4032092        2221300      1605968    59%    /usr
> /dev/hda8        1011928          123832        836692    13%    /var
> I tried numerous times to create an XFS filesystem on /home to no
> avail.  I then tried installing XFS on all partitions.  The main error I
> rec'd on various partitions is:
> Error mounting device hda1 as /boot:  No such device
> This most likely means this partition has not been formatted.
> Press OK to reboot your system.
> Sometimes this error would be on /boot or on /.

I got this error once and it had nothing to do with the partition not being
formatted (although it tricked me for a little while). I would put it more in
the fact (SCSI disk here) that the scsi module didn't load or the boot disk
(network installation here) being damaged or just wrong - are you sure you're
not booting from a non xfs disk? Because what happened to me was I tried using
the network bootdisk from xfs 1.0 iso cd with a xfs 1.0.1 base install in nfs
(didn't think it would make a difference, but it did).

Don't let that generic message fool you. Go into the shell (Alt-F2) and see if
you have the device indeed (my guess is you won't) - that should be your real

Hope to help,

Daniel Fonseca

E-Mail: daniel@xxxxxxxxxxxx
Date: 19-Jul-2001
Time: 03:33:08

This message was sent by XFMail

<Prev in Thread] Current Thread [Next in Thread>