xfs
[Top] [All Lists]

RE: Backup ACLs

To: <linux-xfs@xxxxxxxxxxx>
Subject: RE: Backup ACLs
From: "Juer Lee" <Juer.Lee@xxxxxxxxxx>
Date: Wed, 25 Jul 2001 13:33:04 +0100
Sender: owner-linux-xfs@xxxxxxxxxxx
Thread-index: AcEUiGmRXddmcIeWSE6y/OTZgkRjWwAXpRjgAAJxENAAAXM20AADq/Hw
Thread-topic: Backup ACLs

>-----Original Message-----
>From: Juer Lee 
>Sent: 25 July 2001 11:51
>To: Steve Lord
>Cc: linux-xfs@xxxxxxxxxxx
>Subject: RE: Backup ACLs
>
>
>>
>>>>
>>>>hi,
>>>>
>>>>On Jul 24,  4:57pm, Juer Lee wrote:
>>>>> Subject: RE: Backup ACLs
>>>>> >
>>>>> >> >
>>>>> >> >Take a look on the ftp site, there is an rpm of 1.0.11 of 
>>>>> >xfsdump here:
>>>>> >> >
>>>>> >> >ftp://oss.sgi.com/projects/xfs/download/cmd_rpms/
>>>>> >> >
>>>>> >> >Try this version.
>>>>> >> >
>>>>> >> >Steve
>>>>> >> >
>>>>> >> Thanks.
>>>>> >> 
>>>>> >> Ohmm, I have already downloaded it, but I failed to compile 
>>>>> >that version
>>>>> >> on my machine (Power PC).  So I used version 1.0.2 as I 
>>mentioned
>>>>> >> before. Is it my version 2.95.2 GCC's problem?=20
>>>>> >> 
>>>>> >> Juer
>>>>> >
>>>>> >Hmm, we need more details than 'failed to compile'
>>>>> >
>>>>> >Steve
>>>>> >
>>>>> 
>>>>> When I compiled it, I got error message as 
>>>>> xfs_fsr.c:156: 'O_DIRECT' undeclared here (not in a function)
>>>>> 
>>>>> Thougn I can modify some code for that, I am not sure if 
>>>>other problems
>>>>> I will meet.
>>>>> 
>>>>
>>>>If you compile against the XFS headers from the current
>>>>xfsprogs-devel rpms, you should find this problem goes away.
>>>>The Debian porters came across this problem and helped fix it
>>>>quite awhile ago now.
>>>>
>>>>You will then run into the next problem, which is that there
>>>>are no syscall entry points for the ACL and extended attribute
>>>>system calls for the PowerPC architecture, so you will need to
>>>>make changes to your kernel and to the libattr & libacl source
>>>>to implement this.
>>>>
>>>>I'm surprised that the test you did (from your original mail)
>>>>didn't give you errors when you ran "chacl" the first time...
>>>>did you not see an error like:
>>>>"libacl: acl_set system call not defined for this architecture"?
>>>>
>>>>cheers.
>>>>
>>>>-- 
>>>>Nathan
>>>>
>>>Nathan,
>>>
>>>Oh, yes, I have already changed those code for ACl, but I forgot to
>>>mention all since I just met the problems when using xfsdump. So you
>>>needn't feel strange :) 
>>>I am now using xfsprogs 1.3.1, need I add xfsprogs-devel rpms?
>>>Under ftp://oss.sgi.com/projects/xfs/download/cmd_rpms/, But I find
>>>xfsprogs-1,3,1-pre1.sc.rpm and 
>xfsprogs-devel-1.3.1-pre1.i386.rpm only
>>>there. Which one should I use?
>>>
>>>Juer
>>>
>>
>>I tried to use a different version of xfs-progs-devel, 1.1.3.0-ppc. It
>>still didn't work.:(
>>
>>Juer
>>
>
>I used some foolish ways to solve that compiling problem, it works.
>But when I run xfsrestore, I got WARNING like : 
>xfsrestore: WARNINING: unable to set root extended attribute 
>for 'test':
>Function not implemented (38)
>--- 'test' is a directory I created with some ACLs  before I 
>run command
>xfsdump.
>After I restore them, I can't get the ACLs for them. I think it just
>that WARNINING means.Right?
>I am sure that my kernel has XFS patched already.
>
>My question is:
>How can I fix it?
>
>Juer 
>
>

I think that WARNNING is from 'attr_set' function,because I compiled
attr-1.0.3, when I want to list the attributes of a directory, I got the
same error message... It's PPC's problem as ACL I think.
But does it affect ACLs? I am confusing.  I mean that I couldn't get
error or warning message of ACL.

Juer


<Prev in Thread] Current Thread [Next in Thread>