[Top] [All Lists]

Re: System locking: kernel-2.4.6pre3-xfs

To: Luc Lalonde <llalonde@xxxxxxxxxxxxxxx>
Subject: Re: System locking: kernel-2.4.6pre3-xfs
From: Simon Matter <simon.matter@xxxxxxxxxxxxxxxx>
Date: Thu, 12 Jul 2001 16:47:51 +0200
>received: from mobile.sauter-bc.com (unknown []) by basel1.sauter-bc.com (Postfix) with ESMTP id 2FFA057306; Thu, 12 Jul 2001 16:57:04 +0200 (CEST)
Cc: "linux-xfs@xxxxxxxxxxx" <linux-xfs@xxxxxxxxxxx>
Organization: Sauter AG, Basel
References: <> <3B4DB0D1.FE016E3C@xxxxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
Luc Lalonde schrieb:
> Hello Seth and Simon,
> I figured I'd answer both of you at the same time.
> First off, I do get some strange errors of this type:
> fh_verify: mail/:saved permission failure, acc=1, error=13
> svc: unknown program 100227 (me 100003)
> However, when I searched on Google this was an NFS message that was harmless
> and could be ignored (is this right?).

I get similar messages on a Mandrake 7.0 server where HP-UX and Solaris
clients are connected. It just means someone tried to access NFS files
with not having appropriate permissions. I think this has nothing to do
with your crashes.

> I looked this morning and I see this message (dmesg):
> st0: Block limits 1 - 16777215 bytes

I remember to have the same on my home system which has a Sony DAT drive
connected. I don't see this here at work since DLT seem to be different.
I guess the st kernel module just tells you what the valid blocksizes
are for your DAT drive.
> The crash always happens when the Amanda system is writting to tape.   Could
> this be a hardware problem clue?

What happens if you access the tape by creating a tar archive on it.
it also crash?

> I haven't tried the 1.01 RPMS yet.  I'm on a SuSE7.1 system here so I compile
> my own kernels.

Hmm, I don't know how SuSE handles tape drives. In redhat the st module
loaded at bootup when a tape device is detected. I know that sometimes
one can get problems when you try to load the st module on demand by
I strongly suggest to make sure the st module is not loaded as

> I'm not using any kind of RAID on this system.   It's got four SCSI disks
> connected to the onboard(Adaptec) SCSI controler and a tape (HP-DAT40)
> connected to an Adaptec-30160 controller.

Well, I love Adaptec like other companies like Microsoft, Intel... The
Symbios Logic SCSI have much less problems with Linux.

> Thanks for your help.
> Seth Mos wrote:
> > At 09:20 12-7-2001 -0400, Luc Lalonde wrote:
> > >Hello Folks,
> > >
> > >I'm seem to be having problems on my DELL PowerEdge 2400 running the XFS
> > >kernels.   Every 10 days or so the systems locks and I have to reboot.
> > >I've tried compiling the kernels with gcc-2.95.2, gcc-2.95.3, and
> > >egcs-1.1.2 with the same results.
> > >
> > >I've been folllowing the XFS kernel development and have been trying
> > >updating since 2.4.2-XFS.    I'm wondering at this point if it's not a
> > >hardware problem.  Could it be a problem with the new Adaptec AIC-7xxxx
> > >drivers?   How can I find out if this is the problem?   There doesn't
> > >seem to be any indication of the source of the problem in the log files.
> >
> > no errors or such in dmesg after a week?
> > Have you tried the 1.0.1 rpms yet?
> >
> > That's weird, are you using a raid controller in this box or software raid?
> >
> > Bye
> >
> > --
> > Seth
> > Every program has two purposes one for which
> > it was written and another for which it wasn't
> > I use the last kind.
> --
> Luc Lalonde, Responsable du reseau GIREF
> Telephone: (418) 656-2131 poste 6623
> Courriel: llalonde@xxxxxxxxxxxxxxx

Simon Matter              Tel:  +41 61 695 57 35
Fr.Sauter AG / CIT        Fax:  +41 61 695 53 30
Im Surinam 55
CH-4016 Basel             [mailto:simon.matter@xxxxxxxxxxxxxxxx]

<Prev in Thread] Current Thread [Next in Thread>