xfs
[Top] [All Lists]

Re: Another case of "getfh failed: Operation not permitted"

To: Eric Sandeen <sandeen@xxxxxxx>
Subject: Re: Another case of "getfh failed: Operation not permitted"
From: Jarkko Santala <jake@xxxxxxx>
Date: Thu, 12 Jul 2001 21:21:24 +0300 (EET DST)
Cc: <linux-xfs@xxxxxxxxxxx>
In-reply-to: <3B4DE658.5DD13CB0@xxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
On Thu, 12 Jul 2001, Eric Sandeen wrote:

> > I'm running Linux 2.4.6 + linux-2.4.6-xfs-07052001.patch on a RedHat 7.1
> > based system. When I tried to mount an xfs filesystem (which sits
> > on top of lvm) exported from this box with NFS, I get a "Permission
> > denied" on the client side and "rpc.mountd: getfh failed: Operation not
> > permitted" on the server side.
>
> Oh, and do you have any other patches besides XFS in this kernel?

No, pure 2.4.6 and the xfs patch above, nothing else, but...

You know what? I just put the kgcc compiled one in and now it seems to
work! Ain't that a thing. The previous compile was done with RedHat
package gcc-c++-2.96-81.

Btw, when I was running 2.4.5 the whole thing with NFS worked fine for a
couple hours of very light use. Then it just stopped and a message on the
server console appeared, saying something about "bug in namei.c! Fsck?".
There was also the usual large amount of numbers and stuff, but I couldn't
be bothered to write it all down. After that it stopped working.

Anyway, it seems to work now, compiled with compat-egcs-6.2-1.1.2.14. I'll
let you know if there are problems.

        -jake

-- 
Jarkko Santala <jake@xxxxxxx>  System Administrator  Cell. +358407204512
SSH Communications Security Corp, Helsinki, Finland   http://www.ssh.com
        "If only you had a personality instead of an attitude."


<Prev in Thread] Current Thread [Next in Thread>