xfs
[Top] [All Lists]

Re: [Q] xfs_growfs erro

To: DaiGS <gibsond@xxxxxxxxxxxxxx>
Subject: Re: [Q] xfs_growfs erro
From: Simon Matter <simon.matter@xxxxxxxxxxxxxxxx>
Date: Thu, 19 Jul 2001 15:09:35 +0200
>received: from mobile.sauter-bc.com (unknown [10.1.6.21]) by basel1.sauter-bc.com (Postfix) with ESMTP id F119757306; Thu, 19 Jul 2001 15:19:18 +0200 (CEST)
Cc: theadadv@xxxxxxxxxxxxxx, linux-xfs@xxxxxxxxxxx
Organization: Sauter AG, Basel
References: <019501c1100f$7b854550$2fcca8c0@gibson>
Sender: owner-linux-xfs@xxxxxxxxxxx
> DaiGS schrieb:
> 
> Hi.
> 
> I setup SGI XFS Release 1.0.1 & RedHat 7.1 & LVM 0.9.1Beta.
> 
> I want to grow & decrease LVM XFS partition.
> I make 1024M LVM partition, and run mkfs.xfs.
> I have 1024M xfs partition.
> After I  use 'lvextend tool', grow my test lvm partion  to 2048M.
> And I use xfs_growfs, grow block size 300000.
> XFS partition is 1195200Kbyte now.
> And I think more big partion, but my computer is below error.
> 
> xfs_growfs -D 300001 /mnt/01
> meta-data=/mnt/01                isize=256    agcount=10, agsize=32768
> blks
> data     =                       bsize=4096   blocks=300000,
> imaxpct=25
>             =                       sunit=0      swidth=0 blks,
> unwritten=0
> naming   =version 2              bsize=4096
> log      =internal               bsize=4096   blocks=1200
> realtime =none                   extsz=65536  blocks=0, rtextents=0
> xfs_growfs: ioctl failed - XFS_IOC_FSGROWFSDATA: Unknown error 990
> 
> What means above error?
> What's problem?
> 
> Please Reply.
> Thank you.
> ===================================================================
> 
> Hi.....
> 
>     The same to me ......I got the same problem like
>  that "xfs_growfs: ioctl failed - XFS_IOC_FSGROWFSDATA: Unknown error
> 990".
> 
> In the following, I looked up many HOWTO about that.
> And found some message in "XFS mailing list".
> The one is that after each xfs_growfs run xfs_repair.
> But on above situation, you can not successfully finish xfs_grow,
> which the to me.
>  At this time, I tried a way to successful growing, that is I run
> xfs_repair before run xfs_growfs, and there
> was a wonder result, I sloved the problem on run xfs_growfs. I can
> grow my XFS arbitrarily now......
> 
> I did not stand to the normal setp to do it, but I did successfully,
> WHY....?????
> 

Hi,

I don't know what your problem is exactly but as stated in the FAQ
at least someone was having problem with growing filsystems more
than once. I did not get this problem even when growing 10 times
but what I saw now is that you specified the amount to grow with
the -D option and this could be the reason why it breaks. If the
filesystem is okay and mountable now, could you try the following:

- Reduce the Logical Volume to ~1500M
- grow the fs with xfs_growfs /mnt/01 , fs should then be
  exactly the size of the volume.
- Extend the volume to 1600M
- grow the fs with xfs_growfs /mnt/01
- Extend the volume to 1700M
- grow the fs with xfs_growfs /mnt/01

If this works it means that maybe the xfs_growfs -D option can
be dangerous in certain situations.

-Simon



<Prev in Thread] Current Thread [Next in Thread>