xfs
[Top] [All Lists]

Re: "getfh failed" again - Resolved

To: Martin Apel <apel@xxxxxxxxxxxxx>
Subject: Re: "getfh failed" again - Resolved
From: Eric Sandeen <sandeen@xxxxxxx>
Date: Tue, 28 Aug 2001 11:10:21 -0500
Cc: linux-xfs@xxxxxxxxxxx
References: <Pine.SGI.4.20.0108270920530.331494-100000@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
Martin Apel wrote:
> 
> Hi,
> 
> I tried moving some of my filesystems exported via NFS from ext2 to
> XFS. Unfortunately I had the same error message
>   getfh failed: Operation not permitted
> when trying to mount the filesystem from an NFS client as previously
> discussed on this list. I compiled a 2.4.5 kernel with the XFS 1.0.1
> patches using egcs egcs-2.91.66.1.

Ok, the problem here appears to be that Martin had 

ftp://ftp.namesys.com/pub/reiserfs-for-2.4/linux-2.4.5-reiserfs-quota+knfsd+umount-fix.patch.bz2

applied, which adds an "nfsd_operations" interface between knfsd and the
filesystem.  XFS doesn't have this by default (since this is not part of
the standard kernel) but the patch Jan submitted at

http://marc.theaimsgroup.com/?l=linux-xfs&m=99535721113926&w=2

will probably make these play nice together again.

-Eric

-- 
Eric Sandeen      XFS for Linux     http://oss.sgi.com/projects/xfs
sandeen@xxxxxxx   SGI, Inc.


<Prev in Thread] Current Thread [Next in Thread>