xfs
[Top] [All Lists]

Re: Kernel hangs with mongo.pl benchmark.

To: Keith Owens <kaos@xxxxxxxxxxxxxxxxx>
Subject: Re: Kernel hangs with mongo.pl benchmark.
From: Paul Schutte <paul@xxxxxxxxxxx>
Date: Fri, 31 Aug 2001 02:57:07 +0200
Cc: XFS mailing list <linux-xfs@xxxxxxxxxxx>
References: <7317.999217877@xxxxxxxxxxxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
Debian stable comes with binutils-2.9.5.0.37-1.
Unstable comes with binutils-2.11.90.0.27-2.
It fails on both systems.

According to the version number it should be fine.
I checked on the kdb web pages for clues and saw that I needed a recent
version of binutils.
I then verified that my version was ok.

"locate bfd.h" says there's no such file on any of the 2  systems.

Guess I should install binutils from source ?

Does anyone know whether these files are in another .deb package.

It's really messy when you start mixing packages and installations from
source.

I am very gratefull that you provide XFS packages for most distributions.

Paul


Keith Owens wrote:

> On Thu, 30 Aug 2001 18:49:18 +0200,
> Paul Schutte <paul@xxxxxxxxxxx> wrote:
> >Unfortunetly I can't get kdb to compile.
> >It fails with error:
> >
> >/home/paul/test/linux-2.4-xfs/linux/include/linux/dis-asm.h:148: storage
> >size of `display_endian' isn't known
> >make[3]: *** [kdb_bt.o] Error 1
>
> That field is defined in /usr/include/bfd.h.  You need at least
> binutils-2.9.5.0.22 to compile kdb.


<Prev in Thread] Current Thread [Next in Thread>