xfs
[Top] [All Lists]

Problems with XFS 1.0.2a anaconda

To: <mkp@xxxxxxxxxxxxx>
Subject: Problems with XFS 1.0.2a anaconda
From: Ajay Ramaswamy <ajayr@xxxxxxxxxxxx>
Date: Sun, 2 Dec 2001 19:49:54 +0530 (IST)
Cc: <linux-xfs@xxxxxxxxxxx>
In-reply-to: <Pine.LNX.4.33.0112011848230.22711-100000@xxxxxxxxxxxxxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
Hello,
I have just stated playing around with the installer and making some 
modifications to it when I noticed some problems

1. Why is the installer not adding xfsdump and dependencies to the 
Utilities group? Look at the diffs below

from XFS 1.0.1 for RedHat 7.1
--- comps.rh71  Sun Dec  2 19:07:40 2001
+++ comps.sgi71 Sun Dec  2 19:06:48 2001
@@ -134,6 +134,7 @@
   vixie-cron
   which
   words
+  xfsprogs
   zlib
   (lang ja and arch i386): kon2
   (lang ja and arch i386): kon2-fonts
@@ -843,6 +844,7 @@
   patch
   rcs
   e2fsprogs-devel
+  xfsprogs-devel
   binutils
   gcc
   sparc: gcc-sparc32
@@ -975,6 +977,8 @@
 0 Kernel Development {
   @ Development
   kernel-source
+  !ia64: compat-egcs
+  !ia64: compat-glibc
 }
 
 0 Utilities {
@@ -991,6 +995,10 @@
   bc
   rmt
   dump
+  xfsdump
+  attr
+  acl
+  dmapi
   efax
   make
   lsof

and from XFS 1.0.2a and RedHat 7.2

--- disc1/RedHat/base/comps     Mon Sep 10 06:22:59 2001
+++ xfs/RedHat/base/comps       Fri Oct 26 07:44:25 2001
@@ -121,6 +121,8 @@
   redhat-logos
   redhat-release
   (arch !s390 and arch !s390x): reiserfs-utils
+  (arch !s390 and arch !s390x): xfsprogs
+  lvm-tools
   rootfiles
   rpm
   s390: s390utils

2. In the anaconda rpm
--- anaconda-7.2-rh/scripts/mk-images.i386      Thu Sep  6 03:55:45 2001
+++ anaconda-7.2-sgi/scripts/mk-images.i386     Sun Dec  2 18:20:24 2001
@@ -80,7 +80,7 @@
 IDEMODS=""
 SCSIMODS="sd_mod sr_mod"
 
-SECSTAGE="agpgart msdos vfat raid0 raid1 raid5 ext3 reiserfs $IDEMODS 
$SCSIMODS $LATEUSBMODS"
+SECSTAGE="agpgart msdos vfat raid0 raid1 raid5 ext3 reiserfs xfs $IDEMODS 
$SCSIMODS $LATEUSBMODS"
 
 COMMONMODULES="vfat $USBMODS"
 LOCALMODULES="$COMMONMODULES BusLogic aic7xxx megaraid ncr53c8xx 

I have found that using "pagebuf xfs_support xfs" instead of just "xfs" is 
more reliable and always genarates the correct iso for me otherwise using 
the 2.4.9-13 boot kernel does not work for me.

3. In creating the install image for the CD
--- anaconda-7.2-rh/scripts/upd-instroot        Wed Aug 22 22:03:26 2001
+++ anaconda-7.2-sgi/scripts/upd-instroot       Sun Dec  2 18:20:24 2001
@@ -95,7 +95,7 @@
         ash kon2 e2fsprogs util-linux raidtools popt mount procps rpm
         XFree86 Xconfigurator anaconda anaconda-runtime kudzu-devel
         kudzu db3 rpm-python bzip2 bzip2-libs dosfstools pciutils 
-        reiserfs-utils parted busybox-anaconda"
+        reiserfs-utils xfsprogs xfsdump parted busybox-anaconda"
 
 if [ $ARCH = i386 ]; then
     PACKAGES="$PACKAGES kernel-pcmcia-cs lilo"
@@ -121,7 +121,8 @@
            XFree86-cyrillic-fonts XFree86 Xconfigurator pygnome pygtk
            pygtk-libglade pygnome-libglade pygnome-applet
            pygnome-capplet gdk-pixbuf XFree86-KOI8-R
-           XFree86-KOI8-R-75dpi-fonts pciutils pam reiserfs-utils"
+           XFree86-KOI8-R-75dpi-fonts pciutils pam reiserfs-utils xfsprogs
+          xfsdump"
 
 if [ -z "$NEEDGR" ]; then
     PACKAGESGR="bash"
@@ -202,11 +203,17 @@
 sbin/mkfs.msdos
 sbin/mkfs.vfat
 sbin/mkreiserfs
+sbin/mkfs.xfs
 sbin/mkraid
 sbin/mkswap
 sbin/parted
 sbin/probe
 sbin/tune2fs
+sbin/xfsdump
+sbin/xfsrestore
+sbin/xfs_repair
+usr/sbin/xfs_db
+usr/sbin/xfs_check
 usr/X11R6/lib/X11/Cards
 usr/X11R6/share/Xconfigurator/MonitorsDB
 usr/bin/python*
@@ -296,6 +303,7 @@
 sbin/fsck
 sbin/fsck.ext2
 sbin/fsck.ext3
+sbin/fsck.xfs
 sbin/ifconfig
 sbin/insmod
 sbin/lsmod

as I can see it xfsdump will not run since the necessary libraries are 
nowhere to be found

# ldd /sbin/xfsdump
        libattr.so.0 => /lib/libattr.so.0 (0x40030000)
        libdm.so.0 => /lib/libdm.so.0 (0x40033000)
        libhandle.so.0 => /lib/libhandle.so.0 (0x40039000)
        libc.so.6 => /lib/libc.so.6 (0x4003c000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
#

libhandle is from xfsprogs, libdm is from dmapi & libattr is from attr

4. When I use the XFS 1.0.2 cd in rescue mode it complains that it cannot 
find the filesystems that are specified by LABEL= tags in fstab. I see 
that the label is assigned by

+    def labelDevice(self, entry, chroot):
+        devicePath = entry.device.setupDevice(chroot)
+        label = labelFactory.createLabel(entry.mountpoint, 
self.maxLabelChars)
+        db_cmd = "label " + label
+        rc = iutil.execWithRedirect("/usr/sbin/xfs_db",
+                                    ["xfs_db", "-x", "-c", db_cmd, 
devicePath],+                                    stdout = "/dev/tty5",
+                                    stderr = "/dev/tty5")
+        if rc:
+            raise SystemError
+        entry.setLabel(label)
+

in dispatch.py, but when I do man xfs_db I cannot find any way to set the 
label with command label.

Thank you

regards
Ajay


<Prev in Thread] Current Thread [Next in Thread>