xfs
[Top] [All Lists]

Re: file corruption during emacs build on XFS logical volume

To: Linux XFS <linux-xfs@xxxxxxxxxxx>
Subject: Re: file corruption during emacs build on XFS logical volume
From: Sean Neakums <sneakums@xxxxxxxx>
Date: Thu, 03 Jan 2002 20:04:40 +0000
In-reply-to: <1010087177.12080.104.camel@xxxxxxxxxxxxxxxxxxxx> (Steve Lord's message of "03 Jan 2002 13:46:17 -0600")
Mail-followup-to: Linux XFS <linux-xfs@xxxxxxxxxxx>
References: <6u4rm4r53e.fsf@xxxxxxxxxxxxx> <1009995505.14223.9.camel@xxxxxxxxxxxxxxxxxxxx> <6uy9jgpn2x.fsf@xxxxxxxxxxxxx> <6uu1u4pf48.fsf@xxxxxxxxxxxxx> <1010013019.1281.6.camel@xxxxxxxxxxxxxxxxxxxx> <6upu4spccv.fsf@xxxxxxxxxxxxx> <1010013997.1315.11.camel@xxxxxxxxxxxxxxxxxxxx> <6ulmfgpau5.fsf@xxxxxxxxxxxxx> <6uheq4p9ny.fsf@xxxxxxxxxxxxx> <3C33AF81.AC235AD0@xxxxxxxxxx> <6ubsgbq013.fsf@xxxxxxxxxxxxx> <1010069377.23328.15.camel@xxxxxxxxxxxxxxxxxxxx> <1010072382.23328.38.camel@xxxxxxxxxxxxxxxxxxxx> <6u3d1npgx9.fsf@xxxxxxxxxxxxx> <1010075404.12080.79.camel@xxxxxxxxxxxxxxxxxxxx> <1010076426.12080.86.camel@xxxxxxxxxxxxxxxxxxxx> <6uu1u3nt3h.fsf@xxxxxxxxxxxxx> <1010087177.12080.104.camel@xxxxxxxxxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
User-agent: Gnus/5.090004 (Oort Gnus v0.04) Emacs/21.1 (i386-debian-linux-gnu)
begin  Steve Lord quotation:

> On Thu, 2002-01-03 at 13:16, Sean Neakums wrote:
>> The box I was building on had emacs installed, showed consistent
>> build failure on XFS and consistent build success on ext2.
>> However...
>
> For me it was consistent success with emacs installed, consistent
> failure with emacs removed. This was independent of filesystem type,
> ext3 failed in exactly the same manner as xfs.
>
> The failure looked like this:
>
> + make
> cd lisp && make EMACS="emacs" 
> lispdir="/var/tmp/emacs-20.7-root/usr/share/emacs/site-lisp" all
> make[1]: Entering directory `/usr/src/redhat/BUILD/emacs-20.7/gnus-5.8.8/lisp'
> rm -f *.elc
> W3DIR=no lispdir=/var/tmp/emacs-20.7-root/usr/share/emacs/site-lisp srcdir=. 
> emacs -batch -q -no-site-file -l ./dgnushack.el -f dgnushack-compile
> /bin/sh: emacs: command not found
> make[1]: *** [all] Error 127
> make[1]: Leaving directory `/usr/src/redhat/BUILD/emacs-20.7/gnus-5.8.8/lisp'
> make: *** [lick] Error 2
> error: Bad exit status from /var/tmp/rpm-tmp.26560 (%install)
>
> And this is on a machine which build emacs correctly when an emacs
> package was installed.
>
>> 
>> > However, a build of emacs on a box running ext3 filesystems and no
>> > emacs installed fails with exactly the same error. So it would
>> > appear to not be XFS related at all, and more of an emacs build
>> > issue.
>> >
>> > Can you check out a build on another fs on a box which does not have
>> > emacs installed already? You could just rename your emacs binary
>> > rather than deinstall.
>> 
>> ...I am building now on an ext2 volume, emacs removed.
>> 
>> (The build just passed the dump stage; src/emacs-21.1 is there and
>> src/temacs is not, as the make output indicates should be the case.)
>> 
>> Is there any chance that the mmap issue that Colin mentioned could
>> be cropping up on XFS, too?  Since the emacs21 build has worked for
>> me on 2.4.14-pre7 on an XFS volume, perhaps there were changes
>> introduced or a fix accidentally reversed during a merge with the
>> Linus tree tha might trigger this.
>
> If you look at the failure output, are you getting a message saying
> the command emacs was not found? A few lines up in the output it is
> setting the path:
>
> PATH=/var/tmp/emacs-20.7-root/usr/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/home/tulip15/lord/bin:/usr/local/bin/ptools:/sbin:/usr/sbin:.
>
> this is the path on my machine, the first of those directories has
> an emacs binary in it. I do not know why it does not find it though,
> and as I said, for me, it does not matter which fs type I am using,
> if I have emacs packages installed it finds the binary and works.

I just successfully completed a build on ext2.  I then did another
build on xfs, which failed in the same manner as previously:

  make[2]: *** No rule to make target 
`/home/sneakums/src/emacs/emacs21-21.1/src/../lisp/widget.elc', needed by 
`../etc/DOC'.  Stop.
  make[2]: Leaving directory `/home/sneakums/src/emacs/emacs21-21.1/src'
  make[1]: *** [src] Error 2
  make[1]: Leaving directory `/home/sneakums/src/emacs/emacs21-21.1'
  make: *** [debian/stamp-build] Error 2

These builds were done with the emacs21 package fully de-installed.

My earlier comments about src/emacs-21.1 disappearing were misleading,
by the way.  The emacs binary is built twice, once to bootstrap the
Lisp, and a second time with the full set of features configured.  So
if the build fals before emacs-21.1. is dumped the second time, as
seems to ba happening here, it's not surprisiing surprising that
temacs would have "mysteriously" reappeared.

You're building emacs 20, though, whose build process may be different
from the emacs 21 build process.  There's about three years of
development between those two releases.

-- 
 /////////////////  |                  | The spark of a pin
<sneakums@xxxxxxxx> |  (require 'gnu)  | dropping, falling feather-like.
 \\\\\\\\\\\\\\\\\  |                  | There is too much noise.


<Prev in Thread] Current Thread [Next in Thread>