xfs
[Top] [All Lists]

Re: XFS latest changes, sb corruption?

To: Eric Sandeen <sandeen@xxxxxxx>
Subject: Re: XFS latest changes, sb corruption?
From: Paul Blazejowski <paulb@xxxxxxxxxxxxxxxxxxx>
Date: Sun, 24 Mar 2002 12:26:26 -0500
Cc: <linux-xfs@xxxxxxxxxxx>
In-reply-to: <Pine.LNX.4.33.0203240932170.379-100000@xxxxxxxxxxxxxxxxxxxxxxxx>
References: <Pine.LNX.4.33.0203240932170.379-100000@xxxxxxxxxxxxxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
On Sunday 24 March 2002 10:36 am, you wrote:

> Oh wait, I probably know what this is.
>
> Are you trying to install lilo on your boot partition?
>
> (i.e. "boot = /dev/sda2" in lilo.conf)
>
> You need to use the mbr (boot = /dev/sda, or whatever disk boots)
> (or you could install it on your swap partition, or other non-xfs
> partition).  XFS needs block 0 on the disk, but if you try to install lilo
> there it will overwrite xfs fs structures.
>
> http://oss.sgi.com/projects/xfs/faq.html#lilowork

Yes, my LILO resides on /dev/sda2 which is the root partition with XFS 
filesystem.And i've been doing that for past 2 years or so without any 
problems.My MBR has NTLOADER and to avoid conflicts with it, i  choose to use 
lilo on my / partition.

LILO version is 21.7.5 that shipped with Slackware 8.0.It always worked and i 
knew about the FAQ entry but it never applied in my case until recently.My 
guess is that there's been either a change in XFS or LILO that don't play 
together anymore and i get corrupted superblock on my root....Any comments?

Paul


<Prev in Thread] Current Thread [Next in Thread>