xfs
[Top] [All Lists]

Re: file coruption on power fail

To: Ivan Ivanov <ivandi@xxxxxxxxxxxxxxx>
Subject: Re: file coruption on power fail
From: Mike Baptiste <mike@xxxxxxxxxxxxxxxx>
Date: Thu, 28 Mar 2002 18:39:52 -0500
Cc: linux-xfs@xxxxxxxxxxx
References: <Pine.LNX.4.44.0203251354250.8170-100000@xxxxxxxxxxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020326
FWIW - I had the exact same problem.  I'm running 2.4.18-xfs, compiled
with gcc3.0.4 on RH 7.2  I was running red-carpet to update gnome and it
updated a LOT of core gnome packages.  Well, X froze solid (except for
the mouse)  ctrl-alt-backspace did nothing (2nd system this happened to
me).  Finally after waiting a good long while, I powered down.

When I restarted, I got a bunch of error msgs due to missing libraries
(X and kerberos)  X refused to start.

I did an xfs_repair - no help.  Since I was on XFree 4.1.0, I grabbed
the 4.2.0 rpms and installed those from the command line along with the
kerberos RPMs using the --force option.

After that, everything worked fine.  Nothing else got corrupted - only
the X libraries (well that I've found so far - but I use this system
heavily and everything seems to be happy)

Wish I had more info - but this was at work so I just got it working
again with the rpm install.

Mike

Ivan Ivanov wrote:
| Are there any chances for solving this problem.
|
| I have read all the faq and the XFS white paper.
| I have tried allmost all XFS patches from oss.sgi.com for various kernels
| and know that XFS logs only metadata updates.
| It is fast, has EA and ACL but when the system crashes for any reason most
| of the open files ( including opened ro ) are lost - for example
| XF86Config.
|
| Regards
| Ivan
|



<Prev in Thread] Current Thread [Next in Thread>