xfs
[Top] [All Lists]

Re: latest xfsrestore and acls problem

To: "Jan Derfinak" <ja@xxxxxxxxxxxx>
Subject: Re: latest xfsrestore and acls problem
From: "Dmitry Melekhov" <dm@xxxxxxxxxx>
Date: Fri, 25 Apr 2003 21:32:35 +0400
Cc: <linux-xfs@xxxxxxxxxxx>
References: <Pine.LNX.4.44.0304250836220.22480-100000@xxxxxxxxxxxxxxxxxx>
Sender: linux-xfs-bounce@xxxxxxxxxxx
----- Original Message -----
From: "Jan Derfinak" <ja@xxxxxxxxxxxx>
To: "Dmitry Melekhov" <dm@xxxxxxxxxx>
Cc: <linux-xfs@xxxxxxxxxxx>
Sent: Friday, April 25, 2003 10:41 AM
Subject: Re: latest xfsrestore and acls problem


> On Fri, 25 Apr 2003, Dmitry Melekhov wrote:
>
> > > You writed in your other mail that you used latest XFS. How latest? If
you
> > > mean latest from CVS you cannot combine it with attr 2.2.0. This
confuse
> > > xfsdump/xfsrestore because there was change from xfsroot to trusted
> > > namespace. You must use attr-2.4.2 or XFS before 21 February 2003.
> >
> > I downloaded this patch:
> >
ftp://oss.sgi.com/projects/xfs/download/patches/2.4.20-2003-03-19_04%3A55_UT
C/xfs-2.4.20-all-i386.bz2
>                                                          ^^^^^^^^^^
>
> This kernel uses trusted namespace.
>

I see ...

> >
> > And, where can I get attr-2.4.x?
> > I see only 2.2.x in
ftp://oss.sgi.com/projects/xfs/download/cmd_rpms/SRPMS/
>
> >From CVS or you can download
> ftp://ftp.suse.com/pub/suse/i386/update/8.2/rpm/src/attr-2.4.0-14.src.rpm
>
> It is "only" 2.4.0 but it contains all patches from 2.4.2.

Thank you!
I downloaded it from suse.com.
Thank you, it works OK.
But I found that I still have strange problem with size difference:
original:
/dev/vg02/lvasuconnect
                        355648    337184     18464  95%
/home/samba/docs/asuconnect

copy (xfsdump |rsh xfsrestore):
/dev/vga3/lvasuconnect
                        355648    342636     13012  97%
/home/samba/docs/asuconnect

As you see, files takes more, i.e. I still have the same problem I had with
2.4.19 from SLES8 updates :-(

Can this be because of  new attributes format?

btw, I'll boot server  with Suse's 2.4.20 in Monday and inform you about
results.

Thank you!




<Prev in Thread] Current Thread [Next in Thread>