xfs
[Top] [All Lists]

Re: Installer CD for XFS 1.3

To: Aly Dharshi <aly.dharshi@xxxxxxxx>
Subject: Re: Installer CD for XFS 1.3
From: Steve Lord <lord@xxxxxxx>
Date: 26 Sep 2003 13:59:45 -0500
Cc: linux-xfs@xxxxxxxxxxx
In-reply-to: <1064602134.14988.13.camel@localhost>
Organization:
References: <1064596055.14988.8.camel@localhost> <1064596936.1214.42.camel@xxxxxxxxxxxxxxxxxxxx> <1064602134.14988.13.camel@localhost>
Sender: linux-xfs-bounce@xxxxxxxxxxx
On Fri, 2003-09-26 at 13:48, Aly Dharshi wrote:
> Hello ,
> 
>       I hope that you are well. I think that killing grub was good enough it
> seems to finish the install but boots up in text mode, which is easy to
> fix. Thanks for the advice though.
> 
>       But I encounter rpm installation problems, like trying to update the
> up2date utility, it seems to spit out a whole bunch of db4 related
> errors and that it finds the resource unavailable. I don't know if this
> is something that is related to the installer1.3 as it never was a
> problem in installer1.2
> 
Now you have hit the bug in rpm in the 9.0 release, it attempts to
do O_DIRECT but sends a misaligned buffer. You need to run rpm with
the environment variable LD_ASSUME_KERNEL set to 2.2.5.

Newer rpm packages from rpm.org do not have this problem.

The reason this does not show in normal redhat setups is they have
O_DIRECT turned off in the kernel. We have it enabled for XFS.

Steve

-- 

Steve Lord                                      voice: +1-651-683-3511
Principal Engineer, Filesystem Software         email: lord@xxxxxxx


<Prev in Thread] Current Thread [Next in Thread>