xfs
[Top] [All Lists]

Re: Installer CD for XFS 1.3

To: Steve Lord <lord@xxxxxxx>
Subject: Re: Installer CD for XFS 1.3
From: Aly Dharshi <aly.dharshi@xxxxxxxx>
Date: Fri, 26 Sep 2003 14:02:01 -0600
Cc: linux-xfs@xxxxxxxxxxx
In-reply-to: <1064602785.1211.47.camel@xxxxxxxxxxxxxxxxxxxx>
References: <1064596055.14988.8.camel@localhost> <1064596936.1214.42.camel@xxxxxxxxxxxxxxxxxxxx> <1064602134.14988.13.camel@localhost> <1064602785.1211.47.camel@xxxxxxxxxxxxxxxxxxxx>
Sender: linux-xfs-bounce@xxxxxxxxxxx
Hi Steve,

        I am curious why this rpm problem doesn't occur in the installer1.2 cd
with rpm version 4.2 and does occur in installer1.3, is the O_DIRECT
option turned off for that kernerl ?

        Cheers,

        Aly.


> Now you have hit the bug in rpm in the 9.0 release, it attempts to
> do O_DIRECT but sends a misaligned buffer. You need to run rpm with
> the environment variable LD_ASSUME_KERNEL set to 2.2.5.
> 
> Newer rpm packages from rpm.org do not have this problem.
> 
> The reason this does not show in normal redhat setups is they have
> O_DIRECT turned off in the kernel. We have it enabled for XFS.
> 
> Steve
-- 
Aly S.P Dharshi
aly.dharshi@xxxxxxxx
Southern Alberta Digital Library Project
                                                                                
                                             
        "A good speech is like a good dress
         that's short enough to be interesting
         and long enough to cover the subject"


<Prev in Thread] Current Thread [Next in Thread>