xfs
[Top] [All Lists]

Re: XFS on RHES 3

To: linux-xfs@xxxxxxxxxxx
Subject: Re: XFS on RHES 3
From: Sean Dogar <sean@xxxxxxxxxxxxx>
Date: Thu, 31 Mar 2005 14:23:09 -0700
In-reply-to: <Pine.LNX.4.58.0503311619010.20619@xxxxxxxxxxxxxxxxxx>
References: <424C6879.2060807@xxxxxxxxxxxxx> <Pine.LNX.4.58.0503311619010.20619@xxxxxxxxxxxxxxxxxx>
Sender: linux-xfs-bounce@xxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Fedora/1.7.6-1.2.2
Net Llama! wrote:

>On Thu, 31 Mar 2005, Sean Dogar wrote:
>  
>
>>I'm trying to get XFS support going on an ES 3 machine (it's actually
>>White Box Enterprise Linux, but the kernel source is the same).  There
>>is no way to enable XFS support on the provided source and recompile
>>since the kernel revision is 2.4.21 (XFS not yet in the kernel).  I
>>tried patching it with the 1.3.1 patches downloaded from SGI but there
>>are apparently enough differences between Red Hat's kernel and vanilla
>>to make the patch fail.
>>
>>I tried grabbing 2.4.29-vanilla, compiling, and running with that
>>kernel, but I quickly found out that the libs or other userland programs
>>in ES 3 must be dependent on some of the 2.6 kernel features that they
>>backported (I kept having programs go out to lunch or die; attaching an
>>strace showed that they were making kernel calls for things that weren't
>>there).
>>
>>Does anybody have XFS RPM's for 2.4.21-15smp or a newer RHES kernel?
>>I'd love to just be able to grab a precompiled module, drop it into
>>/lib/modules, and modprobe it.
>>
>>The only other option I see here is to try an upgrade to 2.6, which, if
>>experience is an indicator, could break things in the userland (assuming
>>I can get it to build).  It would require an upgrade to module-utils,
>>which I'm not sure will leave my currently working kernel in a usable
>>state.
>>    
>>
>
>I'm successfully running 2.6.x on RHES3 without any noticable problems.
>XFS works great.
>
>Sorry, i can 't help with playing the kernel SRPM dance.  Redhat makes it
>sufficiently hard that its much faster easier to just use vanilla 2.6.x.
>
>  
>
Did you have to do anything other than upgrading the module-utils?  Did 
it break the 2.4 kernel?

-Sean


[[HTML alternate version deleted]]


<Prev in Thread] Current Thread [Next in Thread>