xfs
[Top] [All Lists]

Badness in mutex_destroy at kernel/mutex-debug.c:458

To: linux-xfs@xxxxxxxxxxx
Subject: Badness in mutex_destroy at kernel/mutex-debug.c:458
From: Nicolas KOWALSKI <Nicolas.Kowalski@xxxxxxx>
Date: Thu, 30 Mar 2006 11:46:50 +0200
Sender: linux-xfs-bounce@xxxxxxxxxxx
Hello,

On my 2.6.16.1 system, when I umount the XFS filesystem, I have this
message:

Badness in mutex_destroy at kernel/mutex-debug.c:458
 [<c0133eb8>] mutex_destroy+0x63/0x6f
 [<f8bac37d>] xfs_qm_destroy+0x70/0x80 [xfs]
 [<f8bac448>] xfs_qm_rele_quotafs_ref+0x89/0xa0 [xfs]
 [<f8bad0ea>] xfs_qm_destroy_quotainfo+0x12/0x73 [xfs]
 [<f8bf3cc5>] xfs_mount_free+0x9a/0x13f [xfs]
 [<f8bf552d>] xfs_unmountfs+0x9d/0xa5 [xfs]
 [<f8bfb799>] xfs_unmount+0x100/0x10c [xfs]
 [<f8c0bc43>] vfs_unmount+0x28/0x2c [xfs]
 [<f8c0b719>] linvfs_put_super+0x30/0x61 [xfs]
 [<c015f562>] generic_shutdown_super+0x83/0x11d
 [<c015ff6b>] kill_block_super+0x1a/0x2e
 [<c015f441>] deactivate_super+0x67/0x7d
 [<c0172634>] sys_umount+0x67/0x6f
 [<c014d329>] sys_munmap+0x3b/0x57
 [<c0172647>] sys_oldumount+0xb/0xe
 [<c0102d8d>] syscall_call+0x7/0xb


It does not seem to cause any harm. I can still mount it, and
xfs_check reports nothing.

Some filesystem informations:

corbeau:~# grep sda3 /proc/mounts
/dev/sda3 /local xfs rw,usrquota,logbufs=8 0 0

corbeau:~# xfs_info /local
meta-data=/local                 isize=256    agcount=16, agsize=1037573 blks
         =                       sectsz=512  
data     =                       bsize=4096   blocks=16601168, imaxpct=25
         =                       sunit=0      swidth=0 blks, unwritten=1
naming   =version 2              bsize=4096  
log      =internal               bsize=4096   blocks=32768, version=1
         =                       sectsz=512   sunit=0 blks
realtime =none                   extsz=65536  blocks=0, rtextents=0




Is this related to this previous message in the list ?

Date: Mon,  6 Feb 2006 14:24:24 +1100 (EST)
From: Nathan Scott <nathans@xxxxxxx>
To: linux-xfs@xxxxxxxxxxx, sgi.bugs.xfs@xxxxxxxxxxxx
Subject: TAKE 949149 - fix mutex diagnostic


Is this fix pending for 2.6.17 ?

Thanks,

-- 
Nicolas


<Prev in Thread] Current Thread [Next in Thread>