xfs
[Top] [All Lists]

Cannot delete a directory on a XFS file system

To: xfs@xxxxxxxxxxx
Subject: Cannot delete a directory on a XFS file system
From: "Grozdan Nikolov (openSUSE Linux)" <microchip@xxxxxxxxxx>
Date: Sun, 13 Jan 2008 17:23:12 +0100
Sender: xfs-bounce@xxxxxxxxxxx
User-agent: KMail/1.9.5
Hi,

I have a small problem with XFS on a small 40 GB IDE disk that I use for my 
music collection. The disk (/dev/hdb) has only one partition on it formatted 
as XFS. On this partition, there is a directory that no matter what I do, I 
cannot delete it. I tried everything, in Konqueror, right-click on the 
directory and choose to delete it. As root on the console 
doing "rm -rf /media/data/DATA/MusicApps" ... but nothing works. 

When I try to "rm -rf" on this directory I get a message saying...

rm: cannot remove directory `MusicApps/Loops/loops/Acid Loops/Bass': Directory 
not empty

But the "Bass" directory is completely empty, there's nothing in there. Also 
when I unmount the file system and do a "xfs_check /dev/hdb1" I get a message 
saying...

link count mismatch for inode 184549517 (name ?), nlink 3, counted 2

I did several times "xfs_repair /dev/hdb1" but I still get the same result. 
xfs_check reports the same message and I still can't get rid of this empty 
directory. I'm using kernel 2.6.24-rc7, but it's the same with other kernels. 
I also did check the partition for bad block with the "badblocks" program, 
but nothing came out, so the disk is just fine.

Any ideas how I can delete this directory?


<Prev in Thread] Current Thread [Next in Thread>