xfs
[Top] [All Lists]

Re: [PATCH] fix dir2 shortform structures on ARM old ABI

To: xfs@xxxxxxxxxxx
Subject: Re: [PATCH] fix dir2 shortform structures on ARM old ABI
From: Luca Olivetti <luca@xxxxxxxxxxx>
Date: Wed, 19 Mar 2008 12:21:42 +0100
In-reply-to: <20080319002307.GA11349@josefsipek.net>
References: <b1b17e290803181649w507322e7mf1410b30a2621506@mail.gmail.com> <20080319002307.GA11349@josefsipek.net>
Sender: xfs-bounce@xxxxxxxxxxx
User-agent: Thunderbird 2.0.0.0 (Windows/20070326)
En/na Josef 'Jeff' Sipek ha escrit:


Thanks for the heads up wrt ARM EABI.

Well, I have a linkstation lspro, even if it's running now "freelink" (i.e. debian, oabi, for the linkstation http://buffalo.nas-central.org/index.php/FreeLink), it's using the stock, eabi[*], kernel (Linux lspro 2.6.12.6-arm1 #2 Mon Jul 23 22:35:39 CEST 2007 armv5tejl GNU/Linux) and xfs works just fine.


[*] though I think, but I'm not sure, it was not the real thing but something that marvell patched in.

However, any later kernel I tried "breaks" xfs (that's why I originally subscribed to this list), i.e. I cannot see the contents of some directories
(more details here: http://buffalo.nas-central.org/forums/viewtopic.php?p=35061#p35061)


The strange thing is that I can mount the failing image on i386, so it probably has the correct structures on disk.

Maybe looking at what marvell/buffalo patched in that kernel could give some insight on the xfs issues with arm.

Bye
--
Luca


<Prev in Thread] Current Thread [Next in Thread>