[Top] [All Lists]

Re: [REVIEW] - cleanup xfs_attr a bit

To: "Christoph Hellwig" <hch@xxxxxxxxxxxxx>
Subject: Re: [REVIEW] - cleanup xfs_attr a bit
From: "Barry Naujok" <bnaujok@xxxxxxx>
Date: Fri, 18 Apr 2008 10:10:22 +1000
Cc: "xfs@xxxxxxxxxxx" <xfs@xxxxxxxxxxx>, xfs-dev <xfs-dev@xxxxxxx>
In-reply-to: <20080417182702.GA7154@xxxxxxxxxxxxx>
Organization: SGI
References: <op.t9qhhmhx3jf8g2@xxxxxxxxxxxxxxxxxxxxxxxxxxxx> <20080417182702.GA7154@xxxxxxxxxxxxx>
Sender: xfs-bounce@xxxxxxxxxxx
User-agent: Opera Mail/9.24 (Win32)
On Fri, 18 Apr 2008 04:27:02 +1000, Christoph Hellwig <hch@xxxxxxxxxxxxx> wrote:

On Thu, Apr 17, 2008 at 12:35:36PM +1000, Barry Naujok wrote:
This patch starts using struct xfs_name more for the xattr code and
is another step for using xfs_name in xfs_da_args.

Also, the cred parameter is removed from xfs_attr_get and xfs_attr_fetch.

Looks good, but I'd really not expected a function called
xfs_attr_name_to_name to do the shutdown check.  Either keep it in the
callers or give the function a different name.

I agree with that sentiment, just couldn't think of a better name :)

<Prev in Thread] Current Thread [Next in Thread>