xfs
[Top] [All Lists]

Re: xfs_repair aborting ... dir2.c:2133

To: "Eric Sandeen" <sandeen@xxxxxxxxxxx>
Subject: Re: xfs_repair aborting ... dir2.c:2133
From: "Paul Guermonprez" <paul@xxxxxxxxxxxxxx>
Date: Sun, 15 Jun 2008 21:00:43 +0200
Cc: xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=googlemail.com; s=gamma; h=domainkey-signature:received:received:message-id:date:from:sender :to:subject:cc:in-reply-to:mime-version:content-type :content-transfer-encoding:content-disposition:references :x-google-sender-auth; bh=FoYlgcZh9oHfTPcg37yVSIelaz7Q7sbPvWmLfz70iwc=; b=xX9ISO4J3qRCjUCng8UplTvItSbAYMoUtNySJifb/B7DU4iWB4/vfyXL1HqRc5nO3B Jzfa/e+Ww3UnfcHa/4rzswtbCM+Pc3M/F9SSa9TaEsHxmVSKtkmv/blXXUNc/Bk/Z7sz /hFqzgO2+yDNcIyeVhDxMHgD6gnLfzoimi9Ao=
Domainkey-signature: a=rsa-sha1; c=nofws; d=googlemail.com; s=gamma; h=message-id:date:from:sender:to:subject:cc:in-reply-to:mime-version :content-type:content-transfer-encoding:content-disposition :references:x-google-sender-auth; b=Aoyk9aLw7PR9nOrDxOhXdbijofSm8JrZU9ImXPzlSfOeQZ5HSzEmtsOSIpWpiXTMfh ta/cpvLX+Vd2DfdBAK5jKHC0i8RWlWyIwPz4wClAAErVYJH/FNT7pClp/7dYf/4PjPw/ QqSnLjZpf1sEGfvypBDBOak7F20xGFrog/ai4=
In-reply-to: <4853F70F.6010400@xxxxxxxxxxx>
References: <74d4a1e10806140124s3ed8dfa6x7e5ca656fea0e06e@xxxxxxxxxxxxxx> <4853F70F.6010400@xxxxxxxxxxx>
Sender: xfs-bounce@xxxxxxxxxxx
hello,

> Do you mean that you did xfsrestore on a previous dump and then tried to
> repair the resulting filesystem?  Maybe the dump was corrupt?

i used dd to copy the xfs part of the original raid disk to my new disk.
in this ss4000e box, xfs partitions are contained in a big partition "IPSTOR"
(built on a raid linear) with a XML descriptor of start/end/...
for logical partitions inside.
so using regular tools was not a option as regular partitions are not seen.
the dd step seems to work fine, but of course i could always try
several times and see if the output is the same.
the output seems like a regular xfs partition,
xfs_repair then mounted as a loop
and got what i was able to get from lost+found.

> If you are willing to provide an xfs_metadump image, Barry would
> probably look into it for you :)

xfs_metadup has been running for more than 6 hours now
(xfs_db at 100% on a recent desktop CPU) and still running.
and all i have is a 230kb file, so i posted it here :
http://dl.free.fr/nHuj52ETY/xfs_metadump.bz2
in theory the important part of the disk contains about
50 folders, with 50 tif files of 30Mo in each, plus other stuff.
tried the lastest version, now using 400%, nice but same result.

> Did anything interesting go wrong before your fs got so mangled?

as i was using this box, i wasn't in contact with the filesystem,
all i can say is that the raid is OK and the disk seem OK too.
( i know it's stupid to use such a box where everything is hidden
won't do it again ! )
the last thing was probably a crach of the system, and impossibility
to reboot the embedded OS of the thing with the drives in.

> xfsrestore did this?  that's pretty weird.

xfs_repair did this. i used dd to copy the data
but again i can't be totally sure of what kind of
strange XFS version IPSTOR is using, perhaps it is not even standard ???
tried to contact them with no luck.

in fact i am trying to exploit my miserable situation to write a
rescue guide for this box, but this last xfs problem is blocking me,
so thanks a lot for your help.

thanks, paul.


<Prev in Thread] Current Thread [Next in Thread>