xfs
[Top] [All Lists]

Re: xfsrestore over ssh?

To: "Timothy Shimmin" <tes@xxxxxxx>
Subject: Re: xfsrestore over ssh?
From: "Richard Hartmann" <richih.mailinglist@xxxxxxxxx>
Date: Wed, 23 Jul 2008 13:39:57 +0200
Cc: "Nathan Scott" <nscott@xxxxxxxxxx>, "Bill Kendall" <wkendall@xxxxxxx>, xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:message-id:date:from:to :subject:cc:in-reply-to:mime-version:content-type :content-transfer-encoding:content-disposition:references; bh=evcHlCfPR3gzfXWJBjuKYyvFWM1bsvo5J0Nry6sV4KA=; b=VjMFOB5eDT+vZOWwu5n7JaR432GQawoFhpwxe2FjcgnTyJyBPspzgEwqAw1C1ME5cQ 8fe6igTmSPvgR5cmRL1QXx5dnGUvHbcxlxfLICQ/vAEQr+CmkD2kP/8XQaKFq94fQSZy Wz2Yk3pjJWTWvKnkwB/IeG+53d/NCm9JFz994=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:to:subject:cc:in-reply-to:mime-version :content-type:content-transfer-encoding:content-disposition :references; b=JxQh2P31EqLRmv1tkBfvBOES5rLlDqQTnklMrQ9ex7QAuG/hSMF/ZfTOM715g4Ijth 1NMoqOCels+ZAwtmrsOLMllw/bsRoGbCb/bzcnX6Ikm0zjgOvQNBiJY/qpWtWEdXlFg0 MhkCZw1Zv+gkAph6lUuRtO84+0d64y42BGSyI=
In-reply-to: <4886790C.7040100@xxxxxxx>
References: <2d460de70807211317m75bc236y403d8fa57514262e@xxxxxxxxxxxxxx> <4884F2A5.5050507@xxxxxxx> <2d460de70807212002k1a95706ic8291e2abd8796b8@xxxxxxxxxxxxxx> <48855B16.4050208@xxxxxxx> <1216708397.4499.57.camel@xxxxxxxxxxxxxxxxxx> <48858676.3030105@xxxxxxx> <2d460de70807220351i7c468de5o33fa5aa5e9ddab99@xxxxxxxxxxxxxx> <4886790C.7040100@xxxxxxx>
Sender: xfs-bounce@xxxxxxxxxxx
On Wed, Jul 23, 2008 at 02:19, Timothy Shimmin <tes@xxxxxxx> wrote:


> Okay, my best guess is that you are trying to restore to a non-xfs
> filesystem. This was fixed again in 2.2.26 so that it would work
> on a non-xfs filesystem.
> Otherwise the xfs ioctl will be being called and get back an EINVAL
> as we saw in the strace.

As I cancelled the first working xfsrestore (kept the strace in the
command), re-mkfs-ed and then restored, there is no way to verify,
but I am _sure_ it was a xfs partition. I did not even know you could
restore to non-xfs so I would never try to do that (not that I would use
anything else, anyway ;)


Thanks for looking into this,
Richard


<Prev in Thread] Current Thread [Next in Thread>