xfs
[Top] [All Lists]

Re: [PATCH 01/12] xfsprogs: some things aren't all that special

To: Alex Elder <aelder@xxxxxxx>
Subject: Re: [PATCH 01/12] xfsprogs: some things aren't all that special
From: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date: Mon, 10 Jan 2011 15:11:38 -0500
Cc: xfs@xxxxxxxxxxx
In-reply-to: <1293741599.2294.342.camel@doink>
References: <1293741599.2294.342.camel@doink>
User-agent: Mutt/1.5.21 (2010-09-15)
On Thu, Dec 30, 2010 at 02:39:59PM -0600, Alex Elder wrote:
> Move the check for short file names out of is_special_dirent() and
> into generate_obfuscated_name().  That way the check is more
> directly associated with the algorithm that requires it.
> 
> Similarly, move the check for inode == 0, since that case has to do
> with storing extended attributes (not files) in the name table.
> 
> As a result, is_special_dirent() is really only focused on whether a
> given file is in the lost+found directory.
> 
> Rename is_special_dirent() to reflect its more specific purpose.
> 
> And use a cast to elminate a compile warning in calls to
> libxfs_da_hashname().

I think Dave's resync of libxfs takes care of that bit.  Either way it
really should be a separate patch.

Also you've stopped overwriting orphanage_ino if it already exists.
I don't think this really matters as we won't have two inodes with the
same name below the root inode.  Either way it should be documented in
the changelog.

Otherwise the change looks good,

Reviewed-by: Christoph Hellwig <hch@xxxxxx>

<Prev in Thread] Current Thread [Next in Thread>