On Mon, Mar 07, 2011 at 05:01:36PM -0600, Alex Elder wrote:
> This time I just scanned most of the change, since it appears
> it's almost the same except for the (renamed) xfs_alloc_busy_trim()
> It looks correct now, but I have a few things for you
> to consider. I'll wait for your response in case you want to
> change anything. After that I'll pull in the three patches
> (probably tomorrow).
For now please just pull the first two. There's a fair chance number
three will change based on how the discard work goes.
> I agree that the notation (from Dave) that you use here
> is very helpful in visualizing what's going on. But
> the underlying code is pretty simple, and it gets somewhat
> lost in the comments I think. I therefore would kind of
> prefer to have the explanation moved up above the function.
> It clearly labels the cases being treated, and references
> to those can be put in the code, below.
> (This is a style thing, so if you feel strongly that it's
> better as you have it, so be it.)
I tried that before, but matching the cases to numbers in comments
wasn't very readable so I switch to this notation.
> All the nice diagrams refer to the variable "fbno"
> and "fend" using "bno" and "end. I think you should
> either drop the "f" in the variables or add it to
> the comments.
Indeed. I did a last minute cleanup to consolidate the duplicate
variables and didn't update the comments.
> (Something like that anyway, I just wanted to provide
> an example rather than just saying "it's wrong.")