On Mon, Jul 11, 2011 at 10:37:43AM +1000, Dave Chinner wrote:
> On Sun, Jul 10, 2011 at 04:49:20PM -0400, Christoph Hellwig wrote:
> > xfs_da_grow_inode and xfs_dir2_grow_inode are mostly duplicate code. Factor
> > the meat of those two functions into a new common helper.
> Hmmmm. I'm in the process of splitting xfs_dir2_grow_inode() into
> data space vs free space variants so I can play speculative
> preallocation tricks in the directory data space to reduce dataspace
> fragmentation for large directories. Combined with a rework of the
> readir readahead code, it significantly reduces IO count and seeks
> for readdir calls...
> I'll probably just rebase on top of this patch, though, because I did
> notice that the two functions were very similar to begin with. ;)
Are you two variants still sharing the core code? If yes rebasing sounds
like the better idea. If the two dir2 variants are different enough
from the da variant I'm fine with postponing this one for now.