xfs
[Top] [All Lists]

Re: stale NFS file handle problem on XFS inode64

To: hank peng <pengxihan@xxxxxxxxx>
Subject: Re: stale NFS file handle problem on XFS inode64
From: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date: Tue, 22 Nov 2011 17:15:15 -0500
Cc: Christoph Hellwig <hch@xxxxxxxxxxxxx>, linux-xfs@xxxxxxxxxxx
In-reply-to: <CAJNJY8Ty+bQpzGL9wq7Qv3ozcKUPwmTyYUeb2wQqZ326K4JeWw@xxxxxxxxxxxxxx>
References: <CAJNJY8Q--O2Z3K6KFxVKOivwaABk+oRtC1y0eQ0nS1WdPNMwsQ@xxxxxxxxxxxxxx> <20111121170459.GA1327@xxxxxxxxxxxxx> <CAJNJY8Ty+bQpzGL9wq7Qv3ozcKUPwmTyYUeb2wQqZ326K4JeWw@xxxxxxxxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
On Tue, Nov 22, 2011 at 08:19:15AM +0800, hank peng wrote:
> > Do you export the root directory of the XFS filesystem, or a
> > subdirectory in it? ??If it's the former it should work in theory,
> > althrough I'm not sure how well 64-bit inode numbers work with a client
> > that old, if it's the latter it needs a few tweaks to work, see
> >
> The following is what I did:
> 1. mkfs.xfs /dev/sdb   (whole disk)
> 2. create a mount point in my root filesystem:
> mkdir /mnt/mymount
> 3. monut xfs with inode64
> mount /dev/sdb /mnt/mymount -o inode64
> 4. export it in NFS /etc/exports
> /mnt/mymount   *(rw, no_root,squash, sync)
> 
> so, is there any problem here?

That should work fine, and I've tried it a lot of times.  Do you see
the same issue when mounting the fs on the server (not recommended for
production use, just for testing!) and accessing it from the 2.6.35
kernel nfs client?

<Prev in Thread] Current Thread [Next in Thread>