xfs
[Top] [All Lists]

Re: What is needed for a stable 2.4 based system?

To: Rainer Krienke <krienke@xxxxxxxxxxxxxx>
Subject: Re: What is needed for a stable 2.4 based system?
From: Eric Sandeen <sandeen@xxxxxxx>
Date: 10 Feb 2003 08:56:20 -0600
Cc: linux-xfs@xxxxxxxxxxx
In-reply-to: <200302101504.56067.krienke@uni-koblenz.de>
References: <Pine.LNX.4.44.0302100707170.20309-100000@stout.americas.sgi.com> <200302101504.56067.krienke@uni-koblenz.de>
Sender: linux-xfs-bounce@xxxxxxxxxxx
Rainer - 

At this time, 1.2 will be released for 2.4.19.  It may be trivial to
merge the patch up to 2.4.20, but all of the testing we have done has
been on 2.4.19, so that will be our release kernel version.

-Eric

On Mon, 2003-02-10 at 08:04, Rainer Krienke wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> On Montag, 10. Februar 2003 14:08, Eric Sandeen wrote:
> >
> > On Mon, 10 Feb 2003, Rainer Krienke wrote:
> > > Hello,
> > >
> > > I want to set up a nfs file server using xfs as the filesystem
> > > (~1TBytes). The server should of course run as stable as possible. So
> > > what I would like to know is what patches I need to get a stable system.
> > > Here is what I downloaded:
> > >
> > > - - kernel 2.4.20 (from kernel.org)
> > > - - the xfs patch for 2.4.20 (xfs-2.4.20-all-i386) from
> > > ftp://oss.sgi.com/projects/xfs/download/patches/2.4.20/
> > >
> > > Are there any futher patches needed.
> > > Is anyone using xfs in a production environment with a similar
> > > configuration?
> > >
> > > Thanks
> > > Rainer
> > > - --
> > > -
> - -- > For starters, the patch you downloaded is a development snapshot, so if
> > it's stable, you're just lucky - it has not undergone extensive testing.
> >
> > If you want patches that have been internally tested at SGI, get one
> > of the Release 1.2pre5 patches from SGI - it is expected that this is the
> > code which will be released as 1.2-final.
> >
> 
> I looked in 
> 
> ftp://oss.sgi.com/projects/xfs/download/Release-1.2pre5/kernel_patches/
> 
> but there is no patch for 2.4.20 only for 2.4.19. Am I looking in the wrong 
> place or will it simply take somewhat more time until there is a stable patch 
> for 2.4.20?
> 
> Thanks Rainer
> - --
> - ---------------------------------------------------------------------------
> Rainer Krienke, Universitaet Koblenz, Rechenzentrum
> Universitaetsstrasse 1, 56070 Koblenz, Tel: +49 261287 -1312, Fax: -1001312
> Mail: krienke@xxxxxxxxxxxxxx, Web: http://www.uni-koblenz.de/~krienke
> Get my public PGP key: http://www.uni-koblenz.de/~krienke/mypgp.html
> - ---------------------------------------------------------------------------
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.0.7 (GNU/Linux)
> 
> iD8DBQE+R7GIaldtjc/KDEoRAmPUAKDiR80dMLSTWtQsNyxkveMH8ubKvgCggQhF
> LHezFelyzblwkYsOyCyLZQ4=
> =44h9
> -----END PGP SIGNATURE-----
-- 
Eric Sandeen      XFS for Linux     http://oss.sgi.com/projects/xfs
sandeen@xxxxxxx   SGI, Inc.         651-683-3102


<Prev in Thread] Current Thread [Next in Thread>